"Aras Innovator client has failed to initialize" .NET Error?

This post has 9 Replies | 4 Followers

Top 500 Contributor
Posts 6
Points 40
sas0 Posted: Wed, Mar 5 2008 11:10 AM

"Aras Innovator client has failed to initialize"   .NET Error?

I have done everything in the aras documentation necessary to setup a client.  I have read all of the other posts and

still no luck.   I have tried setting up on a different client and the server pc.  I cannot get any of them to work. 

Is there some other things I may try that are not listed in the documentation?


I can open up the SQL Server Management Studio, and log in with the following credentials?

 Server Name = server2003\sqlexpress

 Authentication = SQL Server Authentication

 Login = innovator (or sa)

 Password = innovator (or sa)

 

**** Contents of my C:\Program Files\Aras\Innovator\InnovatorServerConfig.xml

<Innovator>
  <UI-Tailoring login_logo="../images/logos/innovator_splash.jpg" branding_img="../images/logos/banner_02.jpg"

product_name="Innovator 8" banner_url="../scripts/banner.aspx" banner_height="50" />
  <operating_parameter key="debug_log_flag" value="false" />
  <operating_parameter key="debug_log_limit" value="10000" />
  <operating_parameter key="debug_log_pretty" value="true" />
  <disabled_operating_parameter key="performance_logging" value="cpu" />
  <operating_parameter key="xslt_processor_debug" value="false" />
  <disabled_operating_parameter key="email_debug_option" value="file" />
  <License lic_type="Unlimited" lic_key="4e0928de075538c593fbdabb0c5ef2c3" />
  <Mail SMTPServer="queue" />
  <operating_parameter key="temp_folder" value="C:\Program Files\Aras\Innovator\Innovator\Server\temp" />
  <operating_parameter key="ServerMethodTempDir" value="C:\Program Files\Aras\Innovator\Innovator\Server\dll" />
  <operating_parameter key="debug_log_prefix" value="C:\Program Files\Aras\Innovator\Innovator\Server\Logs\" />
  <DB-Connection id="InnovatorSolutions" database="InnovatorSolutions" server="server2003\sqlexpress" uid="innovator"

pwd="innovator" dbType="SQL Server" />
</Innovator>


*** Contents of my clients sdns.exe output, sdns.NET 2.0.log


[========================================================]
   Setting security for .NET 2.0 ...
[========================================================]


[--------------------------------------------------------]
   Create new group with name "http://server2003/plm" ...
[--------------------------------------------------------]

Microsoft (R) .NET Framework CasPol 2.0.50727.42
Copyright (c) Microsoft Corporation.  All rights reserved.

Added union code group with "-url" membership condition to the Machine level.
Success

*** I have tried manually opening the "Microsoft .NET Framework 2.0 Configuration" program on the server.

I added (or confirmed):

My Computer>Runtime Security Policy>Enterprise>Code Groups>All_Code>

http://server2003/plm/Client/cbin/*  with both membership conditions checked... Full Trust
http://192.168.1.85/plm/Client/cbin/*  with both membership conditions checked... Full Trust

My Computer>Runtime Security Policy>Machine>Code Groups>All_Code>

http://server2003/plm/Client/cbin/*  with both membership conditions checked... Full Trust
http://192.168.1.85/plm/Client/cbin/*  with both membership conditions checked... Full Trust


ANY OTHER IDEAS???

  • | Post Points: 0
Top 10 Contributor
Posts 200
Points 1,270
Bill replied on Fri, Mar 7 2008 5:35 PM

Are you seeing both errors shown in this post, ot just the second?

http://aras.com/Community/forums/post/67.aspx

Did you make sure to use a new IE window after running the sdns.exe?

-Bill

  • | Post Points: 0
Top 500 Contributor
Posts 6
Points 40
sas0 replied on Mon, Mar 10 2008 11:08 AM

Finally got past the above mentioned "Aras Innovator client has failed to initialize" by changing the IIS virtual directory properties to Execute Permission = Scripts only.

 There was a note in the forums which said,

The permissions must be Scripts only and not Scripts and Executables

 

  • | Post Points: 20
Not Ranked
Posts 2
Points 40

Did everything mentioned in this thread and still getting the error.

Amy more ideas?

  • | Post Points: 20
replied on Wed, Mar 25 2009 3:57 PM

Bill's question is still valid.

 

If you are only recieving the "Application failed to initialize" error, it probably means that you have 2 or more .NET policies on the client that are conflicting and preventing load.

If you are getting both errors, it means you don't have the policy set up at all.

 

-Chris

  • | Post Points: 35
Not Ranked
Posts 2
Points 10
manoc replied on Thu, Mar 26 2009 10:30 PM

I have the same problem.  Why?

Following the methods, it is still not work.

  • | Post Points: 5
Not Ranked
Posts 2
Points 10
manoc replied on Fri, Mar 27 2009 3:30 AM

Finally, I solve the issue this afternoon.

I have Windows 2003 R2 std with IE6 and Client XP sp3 with IE7.

Both are installed .NET 3.5.

Some points there,  you can take a look.  But I am not sure if they are suitable for you.

1. In server, Go into the .Net 2.0 framework configuration, to make sure  that All_Code under the Code Groups is setup right.  I set it Full Trust.  Then I can login Innovator and change the language, etc.

2. In IE7, I found that [Download not signed Activex controls] (under ActiveX controls and plug-ins)also need to be enabled, or I can not login Innovator . 

I am a beginner, and not sure that I say is right.  Good luck.

 

  • | Post Points: 5
Top 50 Contributor
Posts 43
Points 540
Thomas replied on Thu, Apr 14 2011 4:57 PM

Chris,

 

how can these conflicting policies be found and rectified?

Thanks,

Thomas

Regards,

Thomas

  • | Post Points: 20
Top 500 Contributor
Posts 4
Points 40

good question

  • | Post Points: 20
Top 500 Contributor
Posts 6
Points 30
francisco replied on Tue, Dec 6 2011 11:10 AM

Hi,

I am now in Server 2008 R2 and SQL2008 Enterprise. I am using .NET2 and I am still having the same problems.

The instructions are not clear from the beginning.

Did anybody else fixed the issue?

Please advise.

Thank you

  • | Post Points: 5
Page 1 of 1 (10 items) | RSS