An Innovator SQL Procedure Return "Cannot Find Table 0" error message


I have written a SQL Query, Stored Procedure, to Order an xClassTree so that the top level xClasses are in the alphabetical order.

If I run the query just as a SQL query, in SSMS, it works great.

If i run the query as a Stored Procedure in SSMS, created using the innovator SQL itemtype, it works great.

If I try and run it from a javascript method it does not work and generates a SOAP message.

The javascript code uses the following to trigger the run.

In the debugger see the following in resetXClassTopLevelOrder Item, under DOM:XMLDocument, after .apply()

I have tried reorganizing the SQL code and no luck.

Thanks for the help and/or insights.


  • I assume you tested your SQL code in SSMS and then created a new SQL item in Aras. Have you set the "Immediate" Flag and the correct type?

    What right now completely confuses me: Since when it is possible to call SQL procedures from Client side? I made a quick test and it indeed works. But I never thought this would be possible. According to my knowledge. SQL is always called from server Method - never from Client side.

    Does anyone know more?

  • Hello Angela,

    Yes I think so. Here is a snapshot.

    Actually this is my second use of this capability.

    The first one was the SQL Procedure I created to collect all the xProperty data for a single End Item structure and it works great and both are run from the Client Side.

Reply Children
No Data