Multiple Errors: DoPhysicalFiles - -

When I try to delete a file, I get the error "Multiple Errors: DoPhysicalFiles - - " I believe the probable cause of this is because the physical file has been removed, header is still sat in the "File" TOC in admin. How can I overcome this problem?  I have 2000+ files to delete, but I do not know how to check if the physical file exists before trying to delete.   Many thanks, Martin.
  • Hi Martin, are you sure, that your affected files are really not available in the File Vault anymore? I do not have a solution for this issue, but maybe an explanation. I also have 5 files in my Vault that are undeletable. I get the following error message when trying to delete them: Multible bugs: DoPhysicalFiles - Access to the path was denied. (translated version, english version may be differnt) Also my files are still available in the file vault! I even can open them when selecting them in the ItemType File. In my case, the delete problems are caused by security settings in the file vault itself. 1. Go to your file vault and search a file 3. Select the File -> right click -> Properties 4. Go to the Security tab 5. Take a look at the Group or user names box A regular file where everything is ok will contain a "Aras Vault AppPool ASP.NET 4.0" in the Group or user names box A corrupted file doesn´t contain the "Aras Vault AppPool ASP.NET 4.0" user. Instead a local users (in my case it´s myself) is set. Maybe it´s possible to restore the security settings for the complete File Vault. I didn´t fix this yet as only a small number of files was affected. Hope this helps. Angela
  • Hi Angela, On the live server all the files are present and can be accessed, on the test server the vault was not copied across.  This means I can only delete files that have been added to the test server. I want to test a piece of code that deletes a file, but if the file is not present I get an an exception after the code has run. It appears that the File has an onBeforeDelete event that runs an internal method.  This runs after the file meta-data has been deleted, ie try{} catch{} does not catch the exception. Thus I want to be able to detect if the file is present before trying to delete it I have read that I can use request - response to detect if a file exists at a URL, but I don't know how to get the URL to check.  I have tried to copy the link, but the page always succeeds as this takes me to the ARAS Log-in page. see
  • Ok, your DoPhysicalFiles error message is a different one than mine. To think it very simple: When your Vault exists at same instance as your code tree, you could do a simple check of the local files with File.Exists:
    Innovator inn = this.getInnovator();
    string path ="E:\\Aras\\MyVault\\MyDB\\A\\06\\123348FBF4AB2A5B12B53EB0933B7\\MyFile.txt";
    var x = File.Exists(path);
    return inn.newResult("File exists: "+x);
    When you have to use a URL, you propably have to chance the user credentials parameter in the Vault config to get direct access. Then your URL have to look somehow like this: myplm/.../vaultserver.aspx You can build your url string with the filename and id property of the File item.
  • A Big thanks to Mike from support who gave the answer: string fileUrl = inn.getFileUrl(fileId, UrlType.SecurityToken); HttpWebRequest request = (HttpWebRequest)WebRequest.Create(fileUrl); request.Method = "HEAD";   Many thanks, Martin
  • Hi Angela,

    I am getting the same error and with the same reason as yours.

    Could you figure out how to add 'Aras Vault AppPool ASP.NET 4.0' this user to the files?

    Please share. 


  • Hello AngelaIp,

    I wish to asl you as expert of Aras Innovator, How can I check hom much files I have in the File Vault ? 

    Thanks in advance,


  • Go to TOC -> Administration -> FileHandling -> Files -> Do a search and see amount at the bottom.

    Pay attention not to delete something accidentally. 

  • Hi Meismart,

    are you still doing PLM? I right now face the same issue that you had 5 years ago.

    I get the same error message. Certain physical files have been removed from the Vault, but they still appear in the "File" table.

    I would prefer to clean up the wrong entries in the "File" table, but don´t want to erase the data directly in SQL.

    One idea I currently have is to rebuild the missing folder structures with fake files and then finally delete them again.

    But I wonder if you have found a more elegant solution?

    Thanks and best regards!


    If anyone else knows a good solution to this one, please let me know!!!!!


  • Solved it! I didn´t skip the problematic files entries, but repaired them so I finally was able to delete them like regular files.