Error: Cannot access OAuth Server due to 502 (Bad Gateway)

I'm attempting to install Aras 12 on a Windows 10 machine, following this guide:

After a bunch of attempts, I'm pretty sure I have all of the right things installed:

  • .NET Framework 4.7.2
  • ASP.NET Core/.NET Core 2.1.8
  • Microsoft Visual C++ 2015 Redistributable
  • IIS is turned on and all the correct features are activated
  • SQL Server 2014

Aras installs without any issues, but when I try to connect to localhost/InnovatorServer, I get "Error: Cannot access OAuth Server due to 502 (Bad Gateway)"

Going to Windows Event Viewer for more details, I get: 

Application 'MACHINE/WEBROOT/APPHOST/DEFAULT WEB SITE/INNOVATORSERVER/OAUTHSERVER' with physical root 'C:\Program Files (x86)\Aras\Innovator\OAuthServer\' failed to start process with commandline 'dotnet .\Bin\Aras.OAuth.Server.dll', ErrorCode = '0x80004005 : 80008083.

Googling tells me that those error codes mean:

  • 0x80004005 – file is missing or cannot be accessed,
  • 0x80008083 – code for version conflict.

I have confirmed that the dll is in the OAuthServer\Bin file.

I have tried uninstalling and reinstalling everything, restarting the computer between each step. I tried doing a system restore and then reinstalling everything. No matter what, I keep getting this same error, and am not really sure how to proceed.

Any advice would be greatly appreciated.

Parents Reply Children