TypeError: Cannot read properties of undefined (reading 'itemTypeGridPlugin')

Dear team,

We are currently using Aras version Release19. However, when attempting to perform searches for both parts and documents, we encounter an error stating "TypeError: Cannot read properties of undefined (reading 'itemTypeGridPlugin')." This error is causing the search operation to fail. Could you please advise on how to resolve this issue? I have already checked the error log, but I couldn't find any relevant information.

Attaching screenshot for your reference.


S. Senthurpari

  • Hi 

    Below are the some steps you give a try

    1. Try clearing the cache and check.

    2. Validate this error is happening only for particular user or for all the user.

    3. Validate if there is any modification to this file \Aras\Innovator\Innovator\Client\Modules\cui\plugins\itemTypeGridPlugin


    Gobikrishnan R

  • Hi Gobikrishnan,

    Thanks for your reply. In response to your query,  

    1. After cleaning the browser cache, still same error 

    2. I have tried in my country zone, this error is not affected at my credentials but mostly affected other region. All the users are impacted. Searching Part and search Documents failed to respond

    3. I have checked the plugin folder , I dont see any code change difference 

    4. Recently we have rolledout SSO (Single SignOn) through OpenIDConnect , we have used some plugins . I am not sure if it is conflict or override client folder. Let me share the screenshot of SSO plugin

    This is the only change done recently , that to oAuthServer folder, with new plugin


    S. Senthurpari

  • Hi Gobikrishnan

    I have fixed the bug. It is related client side specific error i.e. Action -> Preference. I have done the reset and takes effect.


    S. Senthurpari