No code displayed in Edge/Chrome JS debugging window


When I debug JavaScript code in Aras, the code doesn't appear in the debugging window. When I reset the debugging window to the default settings (F1/Restore defaults and reload in Chrome), it works for some time but then it stop to work again.

I'd like to note that I didn't have this problem before, so I'm wondering if anyone else had the same problem as I did. Version 12.0 sp12.

  • Hi Krepop,

    I have seen this behavior too, but not always. Sometimes code is shown well in the debugger, sometimes not at all or not reliable.

    From my experience this depends on "where" you put the debugger statement. At certain positions it will not work reliable, especially when your code contains functions, classes, async code...

    I assume this is caused by the way browsers load the code. I am not an expert on JS, but the code is not always loaded straight from top to button (hoisting). General functions declarations work different than function expressions. So for some Methods debugger works excellent and others don´t work at all. My "solution" is to try various positions for the debugger statement.

    But that´s just my theory, could be completely wrong. If anyone one knows more, please let me know too!

  • Hi Angela,

    Thank you for sharing your insights. I've tried moving the debugger statement to different positions within the code, but unfortunately, the issue persists. It's worth mentioning that I'm also experiencing this in the 2023 Release Build I'll continue investigating and if I come across a solution, I'll make sure to post it here to help anyone else facing a similar problem.

  • I have the same issue. It is having a significant affect on my productivity.

    I have tried moving the debugger; statement at the top of the method, in the midst of the code, in functions and I still don't see the code.

    It would be a great help if this could be resolved.

    Thanks for asking this question. I'm using R22 with the latest Bowser versions; Edge, Chrome, Firefox.  

  • I've got same issues with Chrome 117+ (older versions still work), no matter the Aras version. Firefox was working until very recently, probably it is the last version that broke too.

    While I have not found any Chrome/FF debugger settings that work reliably, here are some workarounds I use:

    • Use PortableApps and download older versions of Chrome/FF.
    • The issue occurs mostly in Form and Field events, and sometimes in CUI methods. I "detached" the code from the Form/Field event Methods by creating a new Meethod that has just one line code: the aras.evalMethod() function to call my main method (which was before linked directly to the Form/Field event)
  • aras.evalMethod(...) worked beutifully, thanks a lot Alderaan!
  • Krepop, Alderaan, Angela,

    Just as an update.

    Neither Edge or Chrome work at all for debugging with the exception of, as you suggested above, when I use aras.evalMethod(....). In fact Edge has been extremely unstable for general development use.

    Now Firefox was updated, automatically, to 120.0 and I have full debugging capability. For me it has been the most stable browser.

    Innovator R22

    Edge version: 119.0.2151.72

       Issues experienced:

          No js debugging,

          Not Locked exception on a regular basis,

          The method editor [Save] and [Done] button grey out and you can't save the method.

    Chrome version: 119.0.6045.160

       Issues Experienced:

          No js debugging

          Not Locked exception occasionally